PHP 5.1.4 中几个有问题的扩展

2006年5月4日(正好是五四青年节),PHP 发布了 5.1.4,我在升级服务器时,顺便把原来的 PHP 4 升级到了这个版本,居然没有遇到什么问题,原来的程序仍然可以运行得很好,看来,对于一般的应用来说 PHP 5 和 PHP 4 没有多大的兼容性问题。不过 PHP 5.1.4 中有几个扩展好像有问题(也可能是不适合跟 IIS 搭配运行),这几个扩展(包括 PHP 网站上提供的 PECL 扩展)是:php_apc.dll、php_blenc.dll、php_exif.dll、php_operator.dll、php_threads.dll。这些扩展如果打开的话,服务器会非常不稳定,甚至会根本无法运行。另外,Oracle 的扩展似乎不能跟 IIS 搭配使用,只能跟 Apache 搭配。

补充:

今天发现还有一个 php_filter.dll 扩展安装以后会引起一个问题:表单中所有的 HTML 内容会被过滤成纯文本。这会使的大多数网站不能正常运行。所以也建议不要开启这个扩展。

标签: PHP

« 上一篇 | 下一篇 »

只显示10条记录相关文章

1 条回复至 "PHP 5.1.4 中几个有问题的扩展" 的评论

在w32平台上整php肯定会有许多不能正常工作的模块。

由 U 于 2010-12-17 15:00:55 提交#1


发表评论

评论 (必须):